nixos-surface-config/homeManagerModules/zsh.nix
2024-09-12 11:31:24 -04:00

17 lines
351 B
Nix

{config, pkgs, ...}: {
programs.zsh = {
enable = true;
enableSyntaxHighlighting = true;
loginExtra = "sway --unsupported-gpu";
shellAliases = {
"update" = "sudo nixos-rebuild switch --flake /home/rohand/nixos-surface-config#xps";
};
oh-my-zsh = {
enable = true;
plugins = ["git" "vi-mode"];
theme = "afowler";
};
};
}